首页 > 服务端开发 > Ubuntu上报错“error This file was generated by a newer version of protoc”
2019
06-20

Ubuntu上报错“error This file was generated by a newer version of protoc”

问题背景
我在Win10上的Linux子系统上执行sudo apt-get install protobuf-compiler后,正常生成了协议代码,执行编译时报错“error This file was generated by a newer version of protoc”。

解决方法:
得执行完整的安装命令
sudo apt-get install libprotobuf-dev protobuf-compiler

最后编辑:
作者:搬运工
这个作者貌似有点懒,什么都没有留下。

留下一个回复

你的email不会被公开。