首页 > 手游开发 > Unity3D > Unity 2020.1打包APK时报错Could not resolve com.android.tools.build:gradle:3.4.0
2022
05-31

Unity 2020.1打包APK时报错Could not resolve com.android.tools.build:gradle:3.4.0

手有点欠,重装了Unity 2020.1。

装好之后,重新打包APK,居然就报错:Could not resolve com.android.tools.build:gradle:3.4.0

这个错误的原因是项目配置下载gradle时被墙导致。我的解决方法是,去C:\Program Files\Unity\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\GradleTemplates目录

打开baseProjectTemplate.gradle文件;把
repositories {**ARTIFACTORYREPOSITORY**
google()
jcenter()
}
改成
repositories {**ARTIFACTORYREPOSITORY**
maven{ url 'https://maven.aliyun.com/repository/google' }
maven{ url 'https://maven.aliyun.com/repository/jcenter' }
}

最后编辑:
作者:搬运工

留下一个回复

你的email不会被公开。